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1 Introduction

Our program, TerpPaint, is a graphical manipulation program very similar to
Microsoft Paint version 5.0 which commonly comes packaged with Microsoft
Windows 9X/NT/2000/ME/XP. However, TerpPaint version 3 hopes to add
capabilities beyond those found in to Microsoft Paint version 5.0. It will be able
to be run across many platforms including UNIX, Mac OS X and Windows.
TerpPaint will offer a variety of services.

TerpPaint is a drawing tool that can be used to create both simple and
intricate drawings in both black-and-white and in color. Later, these images
can be saved as gif, animated gif, bitmap, or jpeg files, printed, or pasted it into
another document. One can also open already existing files of the above types
to view and/or edit them.

When the user creates an image, there are a variety of shapes that the user
can utilize. These include lines, curves, squares, polygons, ellipses, and rounded
rectangles. In addition to the common shapes, they will have the ability to
freestyle draw with the aid of a spray paint tool, paintbrush, and pencil. Also,
in case the user makes a mistake while drawing, there are both an eraser tool
for touchups and an undo feature which removes the selected actions that where
carried out in error.

TerpPaint also allows the capability to choose which color the user wants
their drawing utensils to be. Additionally, the user can customize the current
colors they have available on their palette. Furthermore, a useful tool to this
product is the zoom tool. This enables the user to make small modifications to
an image by viewing the image at either the 1x, 2x, 4x, or 8x view. These tools
give the user maximum control over their image.

Like any other application, this paint program has a menubar so that the
user can access features not visible on the toolbar in addition to the keyboard
shortcuts. Our ”File” menu will include options to save the current file, open an
existing file, print, and to exit the program. The ”Edit” menu will give the user
the ability to copy a picture, paste a picture from the clipboard, cut out part
of the image, gain access to the undo list, delete a selection, select the entire
picture, manipulate layers in the image, and apply filters. Our ”Image” menu
will allow the user to flip, stretch, skew, invert the colors, adjust the attributes,
or clear an image. It also permits you to draw an image as opaque.

Lastly, our program will be compatible with an entire suite of software being
created by our company. The user will be able to copy text or an image from
any other application of the suite and then paste it statically into our program
and vice-versa. This paint program will suit the needs of any novice graphical
artist or anyone looking to make a quick fix to an existing image.
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2 Working with TerpPaint

2.1 Shape

2.1.1 Free Form Select Tool

Method: Push Free Form Select button on left side bar. Click and hold
once to drag cursor along the path to select

Result: Cursor should change to Lasso. The area within the path dragged
over should be selected

2.1.2 Rectangle Select Tool

Method: Push Selection Button on left side bar. Click and hold once to
drag cursor to diagonally opposite corner of rectangular selection

Result: Cursor should change to precision cursor. A preview of the rec-
tangle is shown while mouse button is held

2.1.3 Magic Wand Selection Tool

Method: Push Magic Wand button on left side bar. Click once on the
canvas

Result: Cursor should change to Magic Wand. Clicking on the canvas will
select the area around the clicked area up to the edge of the canvas or a drastic
change in color

2.1.4 Line Tool

Method: Push Line Button on left side bar. Choose from 5 line thicknesses
in the bottom left corner table. Click on the desired color. Click and hold once
to drag cursor to diagonally opposite corner of desired line
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Result: Cursor should change to Precision cursor. There will be a line
thickness table to select a line thickness. This will change the thickness of the
line to be drawn. Clicking the canvas will root the point at that spot, dragging
the cursor in any direction will give you a preview of the line to be drawn, and
then releasing the cursor will commit it to the canvas. It will display in the
foreground color selected

2.1.5 Curve Tool

Method: Click on the curve tool on the left hand toolbar. Select a fore-
ground color from the Color Palette. Select a curve thickness from above the
Color Palette. Draw a line by clicking on the canvas to set the beginning of the
line, then clicking again to set the end of the line. Click and hold to curve the
line in one direction. Click and hold again to curve in the other direction

Result: Cursor should change to Precision cursor. There will be a line
thickness table to select a line thickness. This will change the thickness of the
line to be drawn. Clicking the canvas will root the point at that spot, dragging
the cursor in any direction will give you a preview of the line to be drawn, and
then releasing the cursor will commit it to the canvas. The next click will pull
the line in the direction of the cursor, and can be held and moved to preview.
The next click will do the same thing.It will display in the foreground color
selected. No more pulling of the line can be performed

2.1.6 Rectangle Tool

Method: Push Rectangle Button on left side bar. Choose from 3 drawing
options in bottom left corner table. Click on the colors desired. Click and hold
once to drag cursor to diagonally opposite corner of desired rectangle

Result: Cursor should change to Precision cursor. The topmost draw op-
tion will draw a rectangle outline in the foreground color. The middle option
will draw a rectangle filled with the background color, and outlined in the fore-
ground color. The Last option will draw a rectangle filled with the foreground
color. A preview of the rectangle is shown while mouse button is held
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2.1.7 Polygon Tool

Method: Push Polygon button on left side bar. Choose from 3 drawing
options in bottom left corner table. Click on the colors desired. The shape
begins at a left mouse press and the first side is completed at the left mouse
release. From that point each side is created by a left mouse press and release
until a side is created with and end at the start point of the first side

Result: Cursor should change to Precision cursor. The topmost drawing
option is to draw an outline in the foreground color. The middle option is to
fill the polygon with the background color and outline in the foreground color.
The last option is to draw the polygon filled with the foreground color

2.1.8 Ellipse Tool

Method: Push Ellipse Button on left side bar. Choose from 3 drawing
options in bottom left corner table. Click on the colors desired. Click and hold
once to drag cursor to diagonally opposite corner of desired ellipse

Result: Cursor should change to Precision cursor. The topmost drawing
option is to draw an ellipse outline in the foreground color. The middle option
is to draw the ellipse filled with the background color and outlined in the fore-
ground color. The Last option is to draw the ellipse filled with the foreground
color. A preview of the line is shown while mouse button is held

2.1.9 Rounded Rectangle Tool

Method: Push Rounded Rectangle button on left side bar. Choose from
3 drawing options in bottom left corner table. Click on the colors desired. Click
and hold once to drag cursor to diagonally opposite corner of desired rectangle

Result: Cursor should change to Precision cursor. The topmost draw op-
tion will draw a rectangle outline in the foreground color. The middle option
will draw a rectangle filled with the background color, and outlined in the fore-
ground color. The Last option will draw a rectangle filled with the foreground
color. A preview of the rectangle is shown while mouse button is held
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2.1.10 Airbrush Tool

Method: Click on the airbrush tool in the left hand toolbar. Select color
from the color palette. Select a stroke size from the lower left hand corner,
above the color palette. Click/hold on the image

Result: Cursor should change to an AirBrush. A stroke size selection list
will appear in the lower left above the color palette. Clicking these sizes should
change the width and shape of the stroke seen on the canvas. It will display in
the foreground color selected

2.1.11 Paintbrush Tool

Method: Click the PaintBrush button on the left hand toolbar. Select a
color from the Color Palette. Select a brush from the brushsize selection grid.
Click/hold on the image to draw with the paintbrush. Clicking with the left
mouse button will paint the foreground color, clicking with the right mouse
button will paint with the background color

Result: Cursor should change to the end of a paintbrush. A brushsize
selection grid will appear in the lower left above the color palette. Clicking
these sizes should change the width and shape of the brush stroke seen on the
canvas. It will show up in the foreground color selected

2.1.12 Pencil Tool

Method: Click on the pencil tool in the left hand toolbar. Select a fore-
ground color to draw with from the Color Palette. Click and hold on the part
of the image you wish to draw on, move your mouse to draw what you want,
and release the mouse button to stop drawing

Result: Cursor should change to a pencil. clicking and/or holding and
dragging the mouse will create a 1 pixel width line over the area dragged, in the
selected foreground color

2.1.13 Eraser Tool

Method: Click the eraser button on the left side bar. Choose a background
color from the Color Palette by right-clicking one of the colors in the palette.
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(When the image is erased, it is replaced by the current background color).
Click on the portion of the image that you wish to erase or click and hold the
mouse button while moving the mouse to erase more of the image

Result: Cursor should change to the size of the stroke that will be erased.
Click and/or hold down the mouse button while moving over the part of the
image to erase and that portion of the image should be erased (replaced with
the current background color)

2.1.14 Color Click Tool

Method: Push Pick Color button on left side bar. Click once on a color
on the canvas

Result: Cursor should change to eyedropper. The color that is under the
bottommost pixel in the cursor will be set to the foreground color

2.1.15 Fill Tool

Method: Click the fill tool on the left side bar. Choose a Color from color
Palette. Click on the canvas where you want to replace the current connected
area of color

Result: Cursor should change to Paint Bucket icon. Clicking on the canvas
should fill the contained area or the entire canvas with the color that is selected.
The Pixel that is filled from should be at the tip end of the paint spilling from
the can icon

2.1.16 Magnify Tool

Method: Click on the magnify tool on the left hand toolbar. Click on the
center of the area you want zoomed

Result: Cursor should change to a magnifying glass. Clicking the canvas
will zoom in to the picture making the image appear bigger by a factor of two
with each click
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2.1.17 Text Tool

Method: Click the text tool button on the left hand toolbar. Select a
foreground color from the Color Palette. Click on the part of the image where
you want the text to be placed

Result: Cursor should change to text insertion cursor. Clicking on the
canvas will be the place where the text will begin. A Window labeled ’Text’
will open with a Text box to type in the text desired to display. There are 2
drop down boxes to select Font and Font size and buttons to select Underline,
Bold, and Italics. It will display in the foreground color selected

2.1.18 Font Type

Method: After a entering the input for the Shape Text and a window
labeled ”Text” appears, click on the font type in the bottom of the Text window.
Select the desired font from the pull-down menu

Result: The font typed into the text box will appear as font of the type
selected

2.1.19 Font Size

Method: After a entering the input for the Shape Text and a window
labeled ”Text” appears, click on the font size in the bottom-right of the Text
window. Select the desired font size from the pull-down menu

Result: The font typed into the text box will appear as font of the size
selected

2.1.20 Text Language

Method: After a entering the input for the Shape Text and a window
labeled ”Text” appears, click on the text language in the bottom-right of the
Text window. Select the desired text language from the pull-down menu

Result: The text will use the language’s characters
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2.2 File

2.2.1 New Image

Method: Click on the File menu (or press ctrl+n). Click on New

Result: Opens a whole new canvas with a new image titled ”untitled #”
where # is a number that is incremented each time a new image is created. The
initial canvas size depends on the settings in the preferences

2.2.2 Open File

Method: Click on the File menu (or press ctrl+o). Click Open. Select
the file you wish to open using the File Explorer. Click Open

Result: Opens a File explorer to find a file to open. There is a drop down
box to select File Type to filter by. Browsing to and selecting a file and pushing
open will open the file on the canvas

2.2.3 Save File

Method: Click on the File menu. Click on Save (or press ctrl+s). If the
image has not been previously saved, select it’s location, name, and file type in
the File Explorer, then click Save

Result: Will save the file to the location and filename if it is already known,
otherwise it will start the Save As... action

2.2.4 Save As

Method: Click on the File menu. Click on Save As. Navigate to the
location you wish to save the file, enter its name and select its file type. Click
Save

Result: Opens a File Explorer to set a location to save the file. There is
a drop down box to select File Type to save as and a Text box to specify the
filename. Clicking save will commit the save
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2.2.5 Close

Method: Click on the File menu. Click on Close (or press alt+F3)

Result: Will ask to save the image before closing. Choosing Yes will start
the Save Routine. Choosing Cancel will abort the Close Routine. Choosing No
will close the canvas without saving and open a New one

2.2.6 Print Preview

Method: Click on the File menu. Click on Print Preview

Result: Opens a new window showing what the document printed would
look like. This window contains buttons to Close the Print Preview window and
to Proceed to the Print Routine

2.2.7 Page Setup

Method: Click on the File menu. Click on Page Setup. Click Ok to
commit changes

Result: Opens the Operating Systems Page setup settings containing Mar-
gins and Page Orientation etc.

2.2.8 Print

Method: Click on the File Menu. Click on Print (or press ctrl+p)

Result: Opens the Operating System’s Print window. Choosing Print will
print the image to the printer selected

2.2.9 Recent Files

Method: Click on the File menu. Click on one of the recently opened
documents from above Exit
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Result: Keeps a listing of Recently Opened Files for quick access. Clicking
on this option will open the selected file after calling the Close Routine on the
current canvas

2.2.10 Exit

Method: Click on the File menu. Click Exit (or press alt+F4)

Result: Closes all open canvases asking to save each one, and exiting the
program

2.3 Edit

2.3.1 Undo

Method: Edit → Undo (Ctrl-Z)

Result: Reverses the last action performed

2.3.2 Action History to Undo

Method: Edit → Action History to Undo. Creates a dynamic list of past
actions to choose to undo

Result: Selecting an action will undo it and everything below it in the list

2.3.3 Redo

Method: Edit → Redo (Ctrl-Y)

Result: Re-applies the last ’undone’ actions, multiple Redo’s supported
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2.3.4 Cut

Method: Edit → Cut (Ctrl-X)

Result: Removes the selection and places it in the “clipboard”

2.3.5 Copy

Method: Edit → Copy (Ctrl-C)

Result: Puts the selection in the clipboard, leaving the selection on the
canvas

2.3.6 Paste

Method: Edit → Paste (Ctrl-V)

Result: The User selects Paste from the edit menu. Then the saved image
in the clipboard shall be pasted as follows:

If the preferences are set to paste to new layer, a new layer is created au-
tomatically as the current topmost layer (when a new layer is created the first
time, it is transparent and set as the current layer the user is working on au-
tomatically, see Layers) and the image in the clipboard is pasted on this new
layer. If the pasted part exceeds the size of current image, that part shall be
cut according to the size of current image.

If preferences are set to paste to current layer, the image in the clipboard is
pasted on the current layer. Here again if the pasted part exceeds the size of
current image, that part shall be cut according to the size of current image.

If preferences are set to paste to new file, the image is pasted in a new
window onto a canvas the size of the image.

In either case, after this operation, the pasted part of image in the current
layer shall remain the current selected object.

2.3.7 Clear Selection

Method: Edit → Clear Selection
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Result: Removes the remove the image contained inside the selection area

2.3.8 Select All

Method: Edit → Select All (Ctrl-A)

Result: Entire canvas is selected

2.3.9 Copy To

Method: Edit → Copy To. Specify file from explorer

Result: Copies the selection to a file that is specified through the save
window that opens

2.3.10 Import

Method: Edit → Import. Select File from explorer. Holding down the
mouse button and drag to move image

Result: User selects Import Image in the Edit Menu. This opens a dialog
where the User chooses an existing file to import

If the preferences are set to import to new layer, a new layer is created
automatically as the current topmost layer (when a new layer is created the
first time, it is transparent and set as the current layer the user is working on
automatically, see Layers) and the image in the selected file is imported onto
this new layer. If the imported image exceeds the size of current image, the
imported image shall be cut according to the size of current image.

If preferences are set to import to current layer, the image in the selected file
is imported onto the current layer. Here again if the imported image exceeds
the size of current image, the imported image shall be cut according to the size
of current image.

If preferences are set to import to new file, the image is imported into a new
window onto a canvas the size of the image.

In either case, after this operation, the imported image in the current layer
shall remain the current selected object
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2.3.11 Preferences

Method: Edit → Preferences (Ctrl-J)

Result: The user can fill in a preference for the number of edits which are
saved in the undo history in a text field called ”undo level”. The user can also
set whether the Copy To... function simply copies to the specified file without
opening it, or whether the file should be opened, as well as whether the file
should be created if it does not exist, by checking the box next to their choice.

The user can specify the time interval used when creating GIF animations
from layers by typing the time (in milliseconds) into a text box. The user can
select the text language through a drop-down menu of supported languages.

The user can specify the default size for a new image, or whether to use the
last used size, using a check box and a text box (if the user will specify the size).
The user can also determine whether Paste, Import, or Paste From... operations
will place the new object in the current layer, in a new layer, or in a new window
when there are multiple layers in the current document, by checking the box
next to the desired option.

2.4 View

2.4.1 Tool Box

Method: Click on the View menu. Click on Tool Box (or press ctrl+T)

Result: Enable/Disable the Toolbox on the left hand side

2.4.2 Color Box

Method: Click on the View menu. Click on Color Box (or press ctrl+L)

Result: Enable/Disable the Color Box in the lower left corner

2.4.3 Status Box

Method: Click on the View menu. Click on Status Box

16



Result: Enable/Disable the Status Box on the lower right corner. (The
Status Box shows the current cursor location)

2.4.4 Layer Box

Method: Click on the View menu. Click on Layer Box

Result: Enable/Disable the Layers Box which is independent of the Main
Window

2.4.5 Zoom Normal

Method: Click on the View menu. Click on or rest cursor above Zoom.
Click on Normal

Result: Will return the zoom to its original setting

2.4.6 Zoom Large

Method: Click on the View menu. Click on or rest cursor above Zoom.
Click on Large

Result: Will zoom in on the canvas

2.4.7 Slideshow

Method: View → Slideshow (Alt-S). Select directory of images from ex-
plorer. Left Click to go to next image, right click to go back

Result: Opens a Full Screen canvas. Left clicking will place the next
picture on the canvas alphabetically, and right clicking will remove it. This is
the case until the last of the files is reached. The images are placed on top of
each other
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2.4.8 View Bitmap

Method: Click on the View menu. Click on View Bitmap

Result: Shows the Current Canvas in fullscreen mode. Clicking the mouse
takes the user back to the Main Window

2.4.9 Animation

Method: Click on the View menu. Click on Animation

Result: Shows an animation

2.5 Image

2.5.1 Flip/Rotate

Method: Select an image using Free Form Select or Rectangle Select but-
ton on left side bar. If no selection takes place, the changes will be applied to
the whole image. Image→Flip/Rotate or (Ctrl - R)

Result: When the users click the ”Flip/Rotate” button, a box shall pop
up. The box includes 3 radio buttons for users to choose to flip the image hori-
zontally, vertically or in a certain angle. Select ”Flip Horizontal”→Ok, then the
whole image/selected image is flipped horizontally. Select ”Flip Vertical”→Ok,
then the whole image/selected image flipped vertically. Select ”Rotate by an-
gle”. Options ”90”, ”180” ”270” become active. Select one of these options and
Click Ok, the whole image/selected image is rotated by specified angle

2.5.2 Stretch/Skew

Method: Select an image using Free Form Select or Rectangle Select but-
ton on left side bar. If no selection takes place, the changes will be applied to
the whole image. Image→Stretch/Skew or (Ctrl - W)
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Result: When the users click the ”Stretch/Skew” button, a box shall pop
up. The box will let the user set the percentage that the user wants to stretch
or skew. To skew the image, under ”Skew” specify number of degrees to skew
picture horizontally/vertically. Click Ok. The whole image/selected image is
skewed horizontally/vertically. To stretch the image, under ”Stretch” specify
percentage to stretch picture horizontally/vertically. Click Ok. The whole im-
age/selected image is stretched horizontally/vertically

2.5.3 Invert Colors

Method: Select an image using Free Form Select or Rectangle Select but-
ton on left side bar. If no selection takes place, the changes will be applied to
the whole image. Image→Invert Colors or (Ctrl - I)

Result: Each color is replaced by its color complement. For example, red
becomes cyan, and blue becomes yellow

2.5.4 Attributes

Method: Click the ”Attributes” button or (Ctrl- E).Then a box pops up

Result: Specify width and length of the image. Specify units in which
length and width is measured (Inches/ Cm/Pixels). Click Ok, then the width
and length of the picture according to specified width, length, and units. The
image is scaled. Specify color of the image. Select ”color”, and then click Ok.
Full color is used in the image instead of black and white. Select ”black and
white”, and then click Ok. Full color in the image and in the left bottom corner
is replaced by shades of black and white

2.5.5 Draw Opaque

Method: Click Image, then check/uncheck a box on left of ”Draw Opaque”

Result: Selecting ”Draw Opaque” specifies that the existing picture will
be covered by the white background of the picture. Unselecting ”Draw Opaque”
specifies that the underlying pictures will be visible through the background of
a selected area in picture
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2.6 Filter

2.6.1 Blur

Method: Click Filter→ Blur or (Ctrl-L) Enter the desired blur factor num-
ber in given textbox

Result: Image being edited is blurred to user’s desire

2.6.2 Brightness

Method: Increase brightness by select and drag the brightness bar to the
right. Decrease brightness by select and drag the brightness bar to the left can
change the brightness effect of the image being edited

Result: Brightness of the image is changed according to user command

2.6.3 Sharpen

Method: Click Filter→ Sharpen or (Ctrl-H)

Result: Image being edited becomes more focused and pixilated

2.6.4 Emboss

Method: Click Filter→ Emboss or (Ctrl-M). Select from 8 separate direc-
tional options for lighting: North, Northwest, West, Southwest, South, South-
east, East, Northeast

Result: Shadowing effect is given to the image being edited according to
the direction specified by user

2.6.5 Edge

Method: Click Filter→ Edge or (Ctrl-D)
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Result: Modify the current image to only display only the edges of the
image

2.7 Colors

2.7.1 Swatches

Method: Click Colors → Edit Colors → Swatches tab Click on a specific
color, adds selected color to Recent, show it in preview Choose another color,
adds selected color to Recent at the top of the list. To select any color in Recent
as background color, click on it

Result: Select OK to apply color to background color

2.7.2 Color HSB

Method: Click Colors → Edit Colors → HSB tab. Change color values:
drag a cursor to a desired color. Type desired number in a box at the right of
H.

Click on Increase/decrease button.
Select S, Change lightness: Drag a cursor to a desired shadow, Type desired

number in a box at the right of S, Click on Increase/decrease button
Select B, Reverse colors: Type desired number in a box at the right of H,

Click on Increase/decrease button

Result: Color in preview is changed based on selected options. Select OK
to change background color to match preview color

2.7.3 Color RGB

Method: Click Colors → Edit Colors → RGB tab
Change R : Drag color cursor on the right of Red, Increase/Decrease Red

click on Increase/Decrease button, Type desired number in a box , Preview
changes

Change G : Drag color cursor on the right of Green, Increase/Decrease Red
click on Increase/Decrease button, Type desired number in a box, Preview
changes
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Change B : Drag color cursor on the right of Blue, Increase/Decrease Red
click on Increase/Decrease button, Type desired number in a box, Preview
changes

Result: Select OK to set the background color to match preview color.
Select Cancel to cancel operation. Select Reset to return to previously selected
background color

2.8 Help

2.8.1 Help Topics

Method: Click Help → Help Topics. After clicking on Help Topics, a
new window appears TerpPaint Help. Click ”Content”. Then there is a list of
various topics appears. Choose a specific topic. Select to display information
on a specific feature of the program

Result: Help information is located in TerpPaint Help

2.8.2 About TerpPaint

Method: Click on Help→About TerpPaint

Result: A new window About TerpPaint contains information about Terp-
Paint

2.9 Layers

2.9.1 Current

Method: To select a new layer put a mark in a circle below ”Current” on
left of the layer’s name
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Result: Makes selected layer an active layer. All the images on the layer
are brought up. Previous layer is moved under the active layer. Default name
of the layer is ”Layer #”

2.9.2 Add

Method: Click on Add or Edit→Layer→Add Layer

Result: A new layer appears at the bottom of list of Layers with a label
saying which layer it is. The created layer is transparent and set as the current
layer the user is working on automatically. A new layer is selected as a ”Current”
layer

2.9.3 Change Name

Method: Click on ”Change Name” button on left of layer’s name that is
to be changed. New window ”New Layer Name” is brought up. Enter the name
in a box below. Click Ok

Result: The name of the layer is changed to a new one. The option allows
multiple layers with the same name

2.9.4 Remove Layer by Name

Method: Click on Remove Layers by Name. Or Edit → Layer→Remove
Layer by Name New Window Remove Layer by Name is brought up. Enter
name of the layer to be removed in a box below. Click Ok

Result: If the layer with such name exists, it will be removed. No changes
if such layer doesn’t exist. No changes if there is only one layer. The top layer
becomes a current layer

2.9.5 Move Up

Method: Click on Move Up. Select a layer to be moved
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Result: Choosing the option move a layer up will reorder the layers by
swapping the current layer with the one above it. The current layer remains the
active layer after this operation. No changes if the current layer is at the top

2.9.6 Move Down

Method: Click on Move Down. Select a layer to be moved

Result: Choosing the option move a layer down will reorder the layers by
swapping the current layer with the one below it. The current layer remains
the active layer after this operation. No changes if the current layer is at the
bottom of list

2.9.7 Move to Front

Method: Click on Move to Front. Select a layer to be moved

Result: Choosing the option Bring Layer to Front will reorder the layers
by removing the current layer from the ordering and adding it as the topmost
layer. The current layer remains the active layer after this operation. No changes
if the current layer is at the top of list

2.9.8 Move to Back

Method: Click on Move to Back. Select a layer to be moved

Result: Choosing the option Send Layer to Back will reorder the layers by
removing the current layer from the ordering and adding it as the bottommost
layer. The current layer remains the active layer after this operation. No changes
if the current layer is at the bottom of list

2.9.9 Remove Current Layer

Method: Click on Remove Current Layer. The current layer should not
be the background layer. The current layer will be deleted as well as anything
drawn on that layer
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Result: The current layer is removed. A layer that was underneath the
removed layer is brought to the top. No changes if there is only one layer

2.9.10 Flatten

Method: Click on Flatten. A layer must be selected for this option, or
Edit →Layer→Flatten Layer

Result: Everything that is drawn on this layer will be copied onto the
background layer and the layer will be deleted. No changes if there is only one
layer

3 Troubleshooting

3.1 I cannot start TerpPaint.

Check to make sure that your system is using Sun Microsystems Java version
1.4.2 or a compatible implementation. Also, make sure you have the latest build
downloadable from http://terppaint.terpoffice.com and double click .compile
before clicking TerpPaint.vbs

3.2 My computer suddenly goes off when I am working
and I havent saved. Will I lose everything?

No. TerpPaint saves 4 backup files periodically. You can retrieve the most
current backup file from the bin sub folder of the folder where you were running
TerpPaint with filename bk.bmp.

3.3 Can I copy something from TerpOffice and paste on
TerpPaint?

Yes. TerpPaint fully supports all TerpOffice applications.

3.4 My tool bar on the left side has disappeared.

Make sure use have checked the Tool Box option under View.
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3.5 The canvas is too small for drawing.

The canvas can be enlarged by clicking and dragging the sides or corners of it.

26


	Introduction
	Working with TerpPaint
	Shape
	Free Form Select Tool
	Rectangle Select Tool
	Magic Wand Selection Tool
	Line Tool
	Curve Tool
	Rectangle Tool
	Polygon Tool
	Ellipse Tool
	Rounded Rectangle Tool
	Airbrush Tool
	Paintbrush Tool
	Pencil Tool
	Eraser Tool
	Color Click Tool
	Fill Tool
	Magnify Tool
	Text Tool
	Font Type
	Font Size
	Text Language

	File
	New Image
	Open File
	Save File
	Save As
	Close
	Print Preview
	Page Setup
	Print
	Recent Files
	Exit

	Edit
	Undo
	Action History to Undo
	Redo
	Cut
	Copy
	Paste
	Clear Selection
	Select All
	Copy To
	Import
	Preferences

	View
	Tool Box
	Color Box
	Status Box
	Layer Box
	Zoom Normal
	Zoom Large
	Slideshow
	View Bitmap
	Animation

	Image
	Flip/Rotate
	Stretch/Skew
	Invert Colors
	Attributes
	Draw Opaque

	Filter
	Blur
	Brightness
	Sharpen
	Emboss
	Edge

	Colors
	Swatches
	Color HSB
	Color RGB

	Help
	Help Topics
	About TerpPaint

	Layers
	Current
	Add
	Change Name
	Remove Layer by Name
	Move Up
	Move Down
	Move to Front
	Move to Back
	Remove Current Layer
	Flatten


	Troubleshooting
	I cannot start TerpPaint.
	My computer suddenly goes off when I am working and I haven™t saved. Will I lose everything?
	Can I copy something from TerpOffice and paste on TerpPaint?
	My tool bar on the left side has disappeared.
	The canvas is too small for drawing.


